ACCORD5
Add a reply

ACCORD5 Company Forums » Trellis Desk » Peer-to-Peer Support

2 Mail Errors when setting up Email Piping in cPanel

 
  • Started 5 years ago by tremorsfsu
  • 3 posts in this topic
  • Latest reply from tremorsfsu
  1. User has not uploaded an avatar

    tremorsfsu
    Member

    I'm getting these 2 Mail Errors when setting up Email Piping in cPanel:

    Warning: require_once(Mail/mimeDecode.php) [function.require-once]: failed to open stream: No such file or directory in /home/user/public_html/helpdesk/includes/class_mailparse.php on line 30

    Fatal error: require_once() [function.require]: Failed opening required 'Mail/mimeDecode.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/user/public_html/helpdesk/includes/class_mailparse.php on line 30

    Thanks in advance for all your help!

    Posted 5 years ago #
  2. User has not uploaded an avatar

    tremorsfsu
    Member

    I searched and didn't find what I was looking for earlier but finally found something on your forum. To anyone else having this problem it looks like this may be of some help. Haven't tried it but wanted to update it just in case you are having the same issue that I am:

    http://forums.accord5.com/topic/piping-issue

    Posted 5 years ago #
  3. User has not uploaded an avatar

    tremorsfsu
    Member

    I tried to follow the thread that I found above and also the document that explains piping. I tried it with all methods of integrating forwards through cPanel. I also tried setting it up to check the POP account.

    I've installed and verified PEAR and the mimeDecode package are installed on the server.

    One of the first tests is with the Mail/mimeDecode.php set to default to use PEAR and the installed packeage. Whenever I try to send an email to an address with the forward set up in cPanel I get this bounceback (along with the original message):

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    pipe to |/home/account/public_html/helpdesk/sources/pipe.php
    generated by generalsupport@domain.com
    local delivery failed

    The following text was generated during the delivery attempt:

    ------ pipe to |/home/account/public_html/helpdesk/sources/pipe.php
    generated by generalsupport@domain.com ------

    <b>Warning</b>: require_once(PEAR.php) [function.require-once]: failed to open stream: No such file or directory in <b>/home/account/public_html/helpdesk/includes/Mail/mimeDecode.php</b> on line <b>65</b>

    <b>Fatal error</b>: require_once() [function.require]: Failed opening required 'PEAR.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in <b>/home/account/public_html/helpdesk/includes/Mail/mimeDecode.php</b> on line <b>65</b>

    ------ This is a copy of the message, including all the headers. ------

    This message is the bounceback I get when I move the Mail/mimeDecode.php directory and file into the includes folder:

    ------ pipe to |/home/account/public_html/helpdesk/sources/pipe.php
    generated by generalsupport@domain.com ------

    <b>Warning</b>: require_once(Mail/mimeDecode.php) [function.require-once]: failed to open stream: No such file or directory in <b>/home/account/public_html/helpdesk/includes/class_mailparse.php</b> on line <b>30</b>

    <b>Fatal error</b>: require_once() [function.require]: Failed opening required 'Mail/mimeDecode.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in <b>/home/account/public_html/helpdesk/includes/class_mailparse.php</b> on line <b>30</b>

    ------ This is a copy of the message, including all the headers. ------

    Any help would be greatly appreciated. I've spent almost an entire day testing various methods from forums and from the Accord5 documentation.

    Thanks,
    Anthony

    Posted 5 years ago #

RSS feed for this topic

Reply

You must log in to post.